#668 ✓resolved
Rik

Error when retrieving My eBay items

Reported by Rik | February 8th, 2009 @ 05:43 AM | in 2.1 Release

Happens both with 2.0.b11-736 and 2.0.b12-749


Sun Feb 08 11:06:48 CET 2009: Done getting the sign in cookie.
Sun Feb 08 14:35:22 CET 2009: Loading page 0 of My eBay for user stoneshop_gs
Sun Feb 08 14:35:22 CET 2009: URL: http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&LogUID=stoneshop_gs&CurrentPage=MyeBayWatching&SessionId=0&Watching.Page=0&MiniSubscriptions.Page=1&View=Watching&SubmitAction.ChangePage=x&ssPageName=STRK:ME:PAGE&FolderId=&GotoPage=1
Sun Feb 08 14:35:24 CET 2009: Bad input tag: button id="EditButton_7173" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
Sun Feb 08 14:35:24 CET 2009: Loading page: http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&CurrentPage=MyeBayBidding
Sun Feb 08 14:35:25 CET 2009: Bad input tag: button id="EditButton_1551" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
Sun Feb 08 14:35:25 CET 2009: No items on page!

The number in the EditButton_nnnn changes each time.

Result is that JBW now only has 12 items loaded out of the 100 or so that My eBay contains.

Comments and changes to this ticket

  • Therese Telepski

    Therese Telepski February 8th, 2009 @ 05:52 AM

    Please within the menu go to

    Edit -> Find

    and activate the appropriate search if not already done.

    You also may need to switch back from the new eBay beta version showing only a very limited number of 'My eBay' items to the old version and turn on a high number of auctions to be shown. As far as I know JBW retrieves only the first page it sees and doesn't perform a multipage search (basically could be done, but makes things much harder as most pages contain more than one 'Got to next page' button). Thus manually call the wanted 'My eBay' page in your browser and adjust settings on eBay accordingly.

    Sincerely,

    Therese

  • Morgan Schweers

    Morgan Schweers February 8th, 2009 @ 11:41 AM

    • Tag set to committed
    • State changed from “new” to “open”

    Greetings,

    I'm also putting in a fix for JBidwatcher 2.0beta12 that if it sees the My eBay Beta page's links to extend the number of items shown per page, it submits the '200 per page' one, and then uses the resultant Watching page...

    -- Morgan Schweers, CyberFOX!

  • Morgan Schweers

    Morgan Schweers February 8th, 2009 @ 11:46 AM

    (from [779]) If there's a link with content '200' on the My eBay watching page, it's probably the new page style, so go ahead and 'click' that link, so we can retrieve up to 200 entries at a time from My eBay.

    200!?? Madness!

    Madness, huh? THIS. IS. EBAY!

    [#668]

  • Rik

    Rik February 8th, 2009 @ 12:09 PM

    @Therese: that is not the problem. Whatever way I try to sync My eBay (automatically or manual), JBW fails after a small (5..10) number of items, then stops.

    @Morgan: there is no link on any of My eBay pages with '200' in it that I can find. At the moment I have exactly 100 items watched, with 76 active, but it's been happening with smaller numbers too. There's one that contains '2008' and one containing '3200' (both as part of the description text), but it's been happening before I added those last Friday.

  • Morgan Schweers

    Morgan Schweers February 8th, 2009 @ 01:31 PM

    Greetings,

    @Rik I believe the problem is that eBay is only showing JBidwatcher 10 items on the first page. In the new My eBay format, they have a link to show up to 200, but in the old format (which JBidwatcher supports a bit better), you have to dig into the My eBay settings to find where to crank that number up to around 100.

    -- Morgan Schweers, CyberFOX!

  • Rik

    Rik February 9th, 2009 @ 01:33 PM

    Well, I'm not using eBay Beta (haven't ever), and while I have changed the number of items per page from 25 to 50, then 100, and back to 50, nothing changes.

    Still that Bad Input Tag error, and just 11 items in JBW at the moment.

    Mon Feb 09 22:30:35 CET 2009: Bad input tag: button id="EditButton_6049" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')" Mon Feb 09 22:30:35 CET 2009: No items on page!

  • Morgan Schweers

    Morgan Schweers February 9th, 2009 @ 01:49 PM

    Greetings,

    Are you using the latest test release of JBidwatcher? If not, give that a try, and let me know if it makes a difference.

    -- Morgan Schweers, CyberFOX!

  • Rik

    Rik February 9th, 2009 @ 02:17 PM

    Doesn't make a difference, sorry:

    
    Mon Feb 09 23:15:08 CET 2009: Loading page 0 of My eBay for user stoneshop_gs
    Mon Feb 09 23:15:08 CET 2009: URL: http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&LogUID=stoneshop_gs&CurrentPage=MyeBayWatching&SessionId=0&Watching.Page=0&MiniSubscriptions.Page=1&View=Watching&SubmitAction.ChangePage=x&ssPageName=STRK:ME:PAGE&FolderId=&GotoPage=1
    Mon Feb 09 23:15:10 CET 2009: Bad input tag: button id="EditButton_9198" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
    Mon Feb 09 23:15:10 CET 2009: Navigating to the '200 at a time' watching page: http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&CurrentPage=MyeBayNextWatching&SubmitAction.ItemsPerPageSave=x&CustomizedContainer=240&ItemsPerPage=200&ViewMYEBAY_NEXT_CONTAINER_CUSTOMIZE&ssPageName=STRK:MEWAX:COUNT:200&View=WatchingNext
    Mon Feb 09 23:15:13 CET 2009: Bad input tag: button id="EditButton_6767" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
    Mon Feb 09 23:15:13 CET 2009: Loading page: http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&CurrentPage=MyeBayBidding
    Mon Feb 09 23:15:13 CET 2009: Not loaded (260356843220).
    Mon Feb 09 23:15:13 CET 2009: Not loaded (260356843374).
    Mon Feb 09 23:15:13 CET 2009: Not loaded (390028102882).
    Mon Feb 09 23:15:13 CET 2009: Not loaded (150324419700).
    Mon Feb 09 23:15:14 CET 2009: Bad input tag: button id="EditButton_5746" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
    Mon Feb 09 23:15:14 CET 2009: No items on page!
    Mon Feb 09 23:15:15 CET 2009: Loaded 380101441984.
    Mon Feb 09 23:15:15 CET 2009: Not loaded (190283641716).
    
    $ rpm -qa | grep java
    java-1_5_0-sun-1.5.0_update17-0.1
    
  • Morgan Schweers

    Morgan Schweers February 14th, 2009 @ 12:42 AM

    Greetings,

    What do you see when you navigate to the above link to My eBay ?

    If that shows your My eBay items correctly, then I'm guessing that maybe the sign-in cookie isn't quite set right.

    -- Morgan Schweers, CyberFOX!

  • Rik

    Rik February 14th, 2009 @ 09:55 AM

    See screenshot. At the bottom it says page 1 of 11; it's displaying 10 items per page.

  • Rik

    Rik February 14th, 2009 @ 10:03 AM

    Via the ebay.com general settings I have now set the page length to 25 (highest it can be set to), and JBidWatcher has collected 16 item (all from the first page only, and it's clearly missing a couple)

  • Izzy

    Izzy February 14th, 2009 @ 12:49 PM

    I have the same issue here with the latest beta12 (using ebays beta pages). From my logs:

    
    Sat Feb 14 21:45:02 GMT+01:00 2009: Bad input tag: button id="EditButton_4514" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
    Sat Feb 14 21:45:02 GMT+01:00 2009: Navigating to the '200 at a time' watching page: http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&CurrentPage=MyeBayNextWatching&SubmitAction.ItemsPerPageSave=x&CustomizedContainer=240&ItemsPerPage=200&ViewMYEBAY_NEXT_CONTAINER_CUSTOMIZE&ssPageName=STRK:MEWAX:COUNT:200&View=WatchingNext
    Sat Feb 14 21:45:05 GMT+01:00 2009: Bad input tag: button id="EditButton_6222" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
    Sat Feb 14 21:45:05 GMT+01:00 2009: Loading page: http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&CurrentPage=MyeBayBidding
    Sat Feb 14 21:45:05 GMT+01:00 2009: Not loaded (120374980082).
    Sat Feb 14 21:45:06 GMT+01:00 2009: Bad input tag: button id="EditButton_5687" class="sfbtn" onclick="return vjo.dsf.EventDispatcher.run(this,event,'click')"
    Sat Feb 14 21:45:06 GMT+01:00 2009: No items on page!
    Sat Feb 14 21:45:07 GMT+01:00 2009: Loaded 200283644993.
    Sat Feb 14 21:45:07 GMT+01:00 2009: Not loaded (360128311608).
    

    followed by some more "Not loaded" lines. JBW beta12 just downloaded today. My watchlist is set to 25 entries, watched items are only 13 - but it already missed number 12 (cannot tell for the others since they had already been in JBW).

  • Maria

    Maria March 11th, 2009 @ 12:01 AM

    I am having the same problem. I have the latest version and was working fine last week. Now its doing this same thing with this new version. I haven't changed any ebay settings or any settings on this application. Not sure what happened. Was there a resolution?

  • Morgan Schweers

    Morgan Schweers April 19th, 2009 @ 01:53 AM

    • Tag changed from committed to committed, myebay

    Greetings,

    Please try adding the following URL as a 'URL Load' search, and seeing if it loads more or less items from your watch list.

    http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&CurrentPage=MyeBayWatching

    Thanks muchly,

    -- Morgan Schweers, CyberFOX!

    {triage}

  • Morgan Schweers

    Morgan Schweers May 16th, 2009 @ 03:58 AM

    • Tag changed from committed, myebay to @moved, committed, myebay
    • Milestone changed from 2.0 Full Release to 2.1 Release

    [milestone:ID#38598 tagged:"@moved" bulk edit command]

  • bve

    bve June 12th, 2009 @ 05:41 AM

    I have the same problem. Adding http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&CurrentPage=MyeBayWa... works sometimes, but not always or not for all items - mostly loads only some. I have And it happens, that my selling items get loaded to the current tab too.

  • JWKrienke

    JWKrienke June 12th, 2009 @ 08:20 PM

    Adding a URL Load search of http://my.ebay.com/ws/eBayISAPI.dll?MyeBay&CurrentPage=MyeBayWa... does not help. Recently have not been able to load any new auctions (despite double clicking on both the url load and on My eBay) and those that are old all now say the seller is "unknown," replacing the sellers' names that were previously there. Also, weirdly, it has put in a snipe of $1.00 on many of the auctions on which I authorized no snipes! This was going on sporadically for several weeks, and now seems permanent.

    What was once a wonderful help in bidding on ebay has now turned into one big frustration!

    This is occurring on my iMac using 10.5.7

  • Julf

    Julf June 13th, 2009 @ 06:39 AM

    I am having the same problem - jBidwatcher doesn't pick up new items anymore. Iḿ running Ubuntu 8.

  • Morgan Schweers

    Morgan Schweers October 12th, 2009 @ 02:14 AM

    • State changed from “open” to “resolved”
    • Tag changed from @moved, committed, myebay to @fixed, @moved, committed, myebay

    Greetings,

    This is believed to be fixed. Either in some earlier release, the current (2.1pre4), or a soon-to-be released version. If the problem still occurs with 2.1pre4 (or a the latest, if a newer version has been released), please re-open.

    -- Morgan Schweers, CyberFOX!

    {triaging}

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Shared Ticket Bins

People watching this ticket

Attachments

Referenced by

Pages